Home > Technik > Höher… schneller… weiter…

Höher… schneller… weiter…

16. Februar 2013 Kommentare

Höher - Schneller - WeiterUnglaublich… aber es hat tatsächlich alles mehr oder minder reibungslos funktioniert. Wie ich ja berichtet hatte, stand bei mir ein Server-Umzug bzw. ein Server-Upgrade an und das habe ich also dann gestern angestoßen. Ich habe den neuen Server zusätzlich aufsetzen lassen und dann Schritt für Schritt alles rübergezogen. Dank einer relativ ausführlichen Vorarbeit und dem einen oder anderen Shell-Script, das ich mir angelegt hatte, war der eigentlich Umzug dann auch nicht wirklich schwierig und ich konnte relativ flott die entsprechenden Daten umkopieren.

Es hat mich also mehr oder minder umsonst gegraust und es ging weitaus reibungsloser als erwartet.

Die Web-Seiten und die User konnte ich vollkommen problemlos umziehen … die Datenbanken haben auch mehr oder minder reibungslos funktioniert und nach einem „flush privileges“ wurden auch die Benutzerkennwörter wieder problemlos angenommen. Nachdem dann die Domaineinträge entsprechend in den Nameservern geändert wurden, konnte ich via Script die Apache-Config und die Exim-Konfig umziehen. Hier musste ich dann jedoch noch den einen oder anderen Klimmzug machen, denn Exim wollte dann doch nicht mehr so ganz laufen. Es hat hier an der Zusammenarbeit zwischen Clamav, Spamassassin und Exim gescheitert. Nachdem ich dann die Config’s des ClamAV-Daemons und die Config von Spamassassin angepasst hatte und die ganze Daemons neu gestartet hatte, lief es dann auch mehr oder minder. Dachte ich zumindest, denn ich musste leider feststellen, dass das Paniclog von Exim immer wieder voll geschrieben wurde. Problem hierbei war ein denkbar einfaches, denn es lag an den Zugriffsrechten. Schnell noch clamav der Exim-Gruppe hinzugefügt und schon nahm Exim die Mails wieder problemlos an.

„Prima“, dachte ich, „dann läuft’s ja jetzt wieder“, aber auch das war ein wenig zu früh gefreut, denn auch wenn Exim die Mails nun annahm, so konnte ich sie dennoch nicht via POP3S abrufen. Problem war hier der gewählte Pop3-Daemon und die entsprechende Konfig hierzu. Auch hier habe ich ein wenig dran rumgeschraubt und e voilà schon ging es wieder.

Jetzt noch schnell das ein oder andere PHP-Modul nachträglich im Apache eingebunden und einige CPAN-Module nachinstalliert und schon liefen die Web-Server auch wieder so, wie sie es vorher taten.

Last but not least … zur Zeit fehlt noch eine einzige Domain, die nicht ordentlich umgehangen wurde. Naja … da kann ich mit leben, denn sobald hier auch die Nameservereinträge angepasst wurden, sollte das auch wieder problemlos laufen.

Fazit:

Der Server-Move hat problemlos funktioniert und nun sollte ich mit der dreifachen Kapazität ein wenig auskommen!

:big_victory_ang:

KategorienTechnik Tags: , ,
  1. Bisher keine Kommentare
  1. Bisher keine Trackbacks
CAPTCHA
*